A-A+

eWebEditor编辑器不支持IE9/IE8/IE7/ff/遨游解决办法

2016年10月15日 web前端设计 暂无评论 阅读 6 views 次

使用eWebEditor编辑器的朋友可能会碰到过eWebEditor编辑器不支持IE9/IE8/IE7/ff/遨游哦,他还是停留在ie6中哦,下面我来给大家介绍快速修正这个问题的解决方法。

编辑器目录JS下的EDITOR.JS文件,找到如下代码:

  1. if (element.YUSERONCLICK) {   
  2. eval(element.YUSERONCLICK + "anonymous()");   
  3. }  

再换成如下代码:

  1. if(navigator.appVersion.match(/8./i)=='8.' || navigator.appVersion.match(/7./i)=='7.'){   
  2. if (element.YUSERONCLICK) eval(element.YUSERONCLICK + "onclick(event)"); //IE8 or IE7  
  3. else { //xiariboke.com  
  4. if (element.YUSERONCLICK) eval(element.YUSERONCLICK + "anonymous()"); //IE6   
  5. }  
标签:

给我留言